can not open .layout files

Questions, tips and tricks, "How can I..."
Post Reply
pidloop
Posts: 3
Joined: Sun 30. Sep 2018, 06:06

can not open .layout files

Post by pidloop » Fri 7. Dec 2018, 02:20

Today I suddenly discovered I can not open any .layout files. I get the popup, below. I have many .layout files that worked fine last week. I noticed a new version was just released so perhaps something was broken? My version is now 6.0.11 (Build 1015). If it matters, I did confirm using Finder "Get Info" that .layout is still associated with RailModeller Pro.app.
Screen Shot 2018-12-06 at 19.19.25.png
Screen Shot 2018-12-06 at 19.19.25.png (69.71 KiB) Viewed 73 times

User avatar
RailModeller Support
Posts: 340
Joined: Mon 24. Nov 2014, 17:27
Contact:

Re: can not open .layout files

Post by RailModeller Support » Fri 7. Dec 2018, 09:28

Hi there,

Quick Tip: Have you tried our FAQ yet? It provides many immediate answers to common questions:
http://www.railmodeller.com/faq-en.html

This is a common issue when SketchUp and RailModeller Pro are both installed on the same Mac as they both claim the .layout extension for documents.

What usually helps is either
  • deleting RailModeller Pro and re-downloading it from the Mac App Store, or
  • deleting either just the Layout app, or
  • deleting the entire SketchUp bundle (if no longer required).
As a third option you can use the .railmodeller extension (starting with RailModeller Pro 6.0.10) for layouts to avoid confusion with SketchUp.

Hope this helps,
Jan
RailModeller Pro - The model railroad layout design package for the Mac

Twitter: https://twitter.com/RailModeller
Instagram: https://www.instagram.com/railmodeller
Facebook: http://fb.me/RailModellerPro
YouTube: http://www.youtube.com/MacRailSoft

pidloop
Posts: 3
Joined: Sun 30. Sep 2018, 06:06

Re: can not open .layout files

Post by pidloop » Fri 7. Dec 2018, 10:38

Changing the extension to .railmodeller worked best for me since I want to keep Sketchup. I also used Finder "Get Info" and changed the association for the extension.

Thanks!

Post Reply